?prefixe=saisies&compatible_spip=4.1

  • https://contrib.spip.net/http.api/ezrest/paquets?prefixe=saisies&compatible_spip=4.1

    ↑ exemple de requête sur l’API de spip-contrib/ezrest pour récupérer les infos d’un plugin (ici saisies) compatible avec une version précise de SPIP (ici 4.1)
    Le retour est un Json dans lequel on pourra trouver (entre autre !) les versions du plugin (ici : donnees > SAISIES > paquet > 4.3.6)
    Devrait permettre de pouvoir récupérer le tag correspondant (ici « v4.3.6 » si la nomenclature de création des tags a été respectée) via une commande spip dl (en mode git) de spip-cli...

    #SPIP #API #plugins #version #tag #spip-cli #compatibilité

    • Salut @cy_altern,

      De mon côté, je viens de faire un script pour lister les commandes git à faire pour cloner un site avec les même versions de plugin déjà installés par Git :

      <code>
      function generategitinstall() {
      FILE=$PWD/$1/../paquet.xml
      if [ -f “$FILE” ]; then
      origin=$(git —git-dir=$1 —work-tree=$PWD/$1/.. config —get remote.origin.url)
      prefix=$(xmllint —xpath “string(/paquet/@prefix)” $PWD/$1/../paquet.xml)
      branch=$(git —git-dir=$1 —work-tree=$PWD/$1/.. branch —show-current)
      echo “git clone $origin $prefix && cd $prefix && git checkout -b$branch && cd ..”
      fi
      }

      function findgits() {
      find ./* -type d -name “.git” -print0 | sort -z |
      while IFS= read -r -d ’’ line; do
      generategitinstall $line
      done
      }
      echo “# spip”
      branch=$(git branch —show-current)
      echo “checkout.php spip -b$branch .”

      echo “# plugins”
      cd plugins
      findgits
      cd ..
      </code>